Octokit.NET v0.24.0 Release Notes

Release Date: 2017-01-17 // about 7 years ago
  • Features/Enhancements

    • ➕ Add GetAll method to OrganizationsClient - #1469 via malamour-work
    • ➕ Add missing fields to Repository class - HasPages, SubscribersCount, Size - #1473 via ryangribble
    • 👍 Allow base64 content for create/update file - #1488 via laedit
    • ➕ Add HtmlUrl field to Milestone class - #1489 via StanleyGoldman
    • ➕ Add support for passing sort options to IssueCommentsClient.GetAllForRepository() - #1501 via pjc0247
    • 📇 Rename PullRequest.Comment to PullRequest.ReviewComment for better accuracy - #1520 via bmeverett
    • 👀 Introduce AbuseException - #1528 via SeanKilleen
    • ➕ Add Id field to PullRequest class - #1537 via YunLi1988
    • 0️⃣ Unparseable ApiErrors should now fall back to better default error messages - #1540 via SeanKilleen

    🛠 Fixes

    • 🛠 Fix errors in ObservableEventsClient caused by incorrect return types - #1490 via StanleyGoldman
    • ➕ Add missing SecurityCritical attribute on GetObjectData() overrides - #1493 via M-Zuber
    • 🛠 Fix exceptions in Events API by adding missing event types to EventInfo enumeration - #1536 via lynnfaraday
    • ➕ Add new AccountType "Bot" to prevent deserialization errors - #1541 via ryangribble

    📚 Documentation Updates

    💥 Breaking Changes

    • ⚡️ Creating and Editing Issues (and PullRequests) using NewIssue and IssueUpdate requests
      🗄 should now use the Assignees collection rather than the now deprecated Assigneefield.
      Both fields can't be specified on the same request, so any code still usingAssigneewill
      need to explicitly setAssigneestonull to avoid Api validation errors.
    • OrganizationsClient.GetAll(string user) has been marked obsolete in favour of
      OrganizationsClient.GetAllForUser(string user)
    • PullRequest.Comment has been marked obsolete in favour of PullRequest.ReviewComment
    • Several EventsClient methods previously returned the incorrect Activity response class.
      This has been corrected to IssueEvent which although is now correct could break calling
      code that was written assuming this previous incorrect return type.